Vulnerabilidad en el demonio CacheFS de Solaris


El demonio CacheFS de Solaris contiene un desbordamiento de búfer que
permite la ejecución de código arbitrario en el servidor, con
privilegios de administrador o "root".
CacheFS (cachefsd) es un demonio accesible por RPC (llamada a
procedimiento remoto), utilizado para optimizar el acceso a servidores
remotos NFS.

Las versiones de CacheFS contenidas en Solaris 2.5.1, 2.6, 7 y 8 (tanto
x86 como Sparc), son susceptibles a un ataque de desbordamiento de búfer
que permite la ejecución de código arbitrario en el servidor, con
privilegios de administrador o "root". El ataque, vía RPC, puede
realizarse de forma remota.

La recomendación es desactivar CacheFS si no se utiliza, hasta contar
con un parche. Si dicho demonio es imprescindible en el sistema, hasta
que se disponga de un parche se debe limitar el tráfico RPC a máquinas
de confianza. SUN todavía no ha publicado un parche oficial.


Más Información:

M-078: Sun Heap Overflow in Cachefs Daemon (cachefsd)
http://www.ciac.org/ciac/bulletins/m-078.shtml

Sun Microsystems cachefsd Buffer Overflow Vulnerability
http://www.auscert.org.au/Informatio...AA-2002.01.txt

CERT® Advisory CA-2002-11 Heap Overflow in Cachefs Daemon (cachefsd)
http://www.cert.org/advisories/CA-2002-11.html

Synopsis: Buffer Overflow in cachefsd in Solaris
http://sunsolve.sun.com/pub-cgi/retr...salert%2F44309

Overflow de Heap en el Demonio Cachefs
http://www.unam-cert.unam.mx/Boletin...-2002-011.html