Resultados 1 al 1 de 1

Tema: Debian, multiarquitectura

  1. #1 Debian, multiarquitectura 
    Iniciado
    Fecha de ingreso
    Jul 2006
    Mensajes
    18
    Descargas
    5
    Uploads
    0
    Hola
    Estoy tratando de instalar un programa, MNova (MestreNova), el cual corresponde a la arquitectura i386 en Debian Wheeze amd64.
    Al parecer la mutiarquitectura no esta funcionando bien, o me estoy equivocando en algo.
    Datos del SO
    Código:
    #uname -a
    Linux <nombre> 3.2.0-4-amd64 #1 SMP Debian 3.2.54-2 x86_64 GNU/Linux
    # dpkg --print-architecture
    amd64
    # dpkg --print-foreign-architectures
    i386
    Lo que sucede al intentar instalar MNova

    Código:
    # dpkg -i mestrenova_9.0.0-12821_i386.deb 
    Seleccionando el paquete mestrenova previamente no seleccionado.
    (Leyendo la base de datos ... 96800 ficheros o directorios instalados actualmente.)
    Desempaquetando mestrenova (de mestrenova_9.0.0-12821_i386.deb) ...
    dpkg: problemas de dependencias impiden la configuración de mestrenova:
     mestrenova depende de libc6 (>= 2.13).
     mestrenova depende de libstdc++6 (>= 4.7.2).
     mestrenova depende de libgcc1 (>= 4.7.2).
     mestrenova depende de libaudio2 (>= 1.9.3).
     mestrenova depende de libxt6 (>= 1.1.3).
     mestrenova depende de libglib2.0-0 (>= 2.33.12+really2.32.4).
     mestrenova depende de libfreetype6 (>= 2.4.9).
     mestrenova depende de libsm6 (>= 1.2.1).
     mestrenova depende de libice6 (>= 1.0.8).
     mestrenova depende de libxi6 (>= 1.6.1).
     mestrenova depende de libxrender1 (>= 0.9.7).
     mestrenova depende de libxrandr2 (>= 1.3.2).
     mestrenova depende de libxfixes3 (>= 5.0).                                                                                      
     mestrenova depende de libxcursor1 (>= 1.1.13).                                                                                  
     mestrenova depende de libxinerama1 (>= 1.1.2).                                                                                  
     mestrenova depende de libfontconfig1 (>= 2.9.0).                                                                                
     mestrenova depende de libxext6 (>= 1.3.1).                                                                                      
     mestrenova depende de libx11-6 (>= 1.5.0).                                                                                      
     mestrenova depende de libxau6 (>= 1.0.7).                                                                                       
     mestrenova depende de libpcre3 (>= 8.30).                                                                                       
     mestrenova depende de zlib1g (>= 1.2.7.dfsg)                                                                                    
    dpkg: error al procesar mestrenova (--install):
     problemas de dependencias - se deja sin configurar
    Se encontraron errores al procesar:
     mestrenova
    Al querer instalar libc6:i386

    Código:
    # apt-get install libc6:i386
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias       
    Leyendo la información de estado... Hecho
    Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
    Los siguientes paquetes tienen dependencias incumplidas:
     libc6 : Rompe: libc6:i386 (!= 2.18-4) pero 2.13-38+deb7u1 va a ser instalado
     libc6:i386 : Depende: libgcc1:i386 pero no va a instalarse
                  Recomienda: libc6-i686:i386 pero no va a instalarse
                  Rompe: libc6 (!= 2.13-38+deb7u1) pero 2.18-4 va a ser instalado
     mestrenova:i386 : Depende: libstdc++6:i386 (>= 4.7.2) pero no va a instalarse
                       Depende: libgcc1:i386 (>= 4.7.2) pero no va a instalarse
                       Depende: libaudio2:i386 (>= 1.9.3) pero no va a instalarse
                       Depende: libxt6:i386 (>= 1.1.3) pero no va a instalarse
                       Depende: libglib2.0-0:i386 (>= 2.33.12+really2.32.4) pero no va a instalarse
                       Depende: libfreetype6:i386 (>= 2.4.9) pero no va a instalarse
                       Depende: libsm6:i386 (>= 1.2.1) pero no va a instalarse
                       Depende: libice6:i386 (>= 1.0.8) pero no va a instalarse
                       Depende: libxi6:i386 (>= 1.6.1) pero no va a instalarse
                       Depende: libxrender1:i386 (>= 0.9.7) pero no va a instalarse
                       Depende: libxrandr2:i386 (>= 1.3.2) pero no va a instalarse
                       Depende: libxfixes3:i386 (>= 5.0) pero no va a instalarse
                       Depende: libxcursor1:i386 (>= 1.1.13) pero no va a instalarse
                       Depende: libxinerama1:i386 (>= 1.1.2) pero no va a instalarse
                       Depende: libfontconfig1:i386 (>= 2.9.0) pero no va a instalarse
                       Depende: libxext6:i386 (>= 1.3.1) pero no va a instalarse
                       Depende: libx11-6:i386 (>= 1.5.0) pero no va a instalarse
                       Depende: libxau6:i386 (>= 1.0.7) pero no va a instalarse
                       Depende: libpcre3:i386 (>= 8.30) pero no va a instalarse
                       Depende: zlib1g:i386 (>= 1.2.7.dfsg) pero no va a instalarse
                       Depende: libffi5:i386 (>= 3.0.10) pero no va a instalarse
                       Depende: libuuid1:i386 (>= 2.20.1) pero no va a instalarse
                       Depende: libexpat1:i386 (>= 2.1.0) pero no va a instalarse
                       Depende: libxcb1:i386 (>= 1.8.1) pero no va a instalarse
                       Depende: libxdmcp6:i386 (>= 1.1.1) pero no va a instalarse
                       Depende: libssl1.0.0:i386 (>= 1.0.1e) pero no va a instalarse
                       Depende: libgl1-mesa-glx:i386 (>= 8.0.5) pero no va a instalarse
                       Depende: libglapi-mesa:i386 (>= 8.0.5) pero no va a instalarse
                       Depende: libxdamage1:i386 (>= 1.1.3) pero no va a instalarse
                       Depende: libx11-xcb1:i386 (>= 1.5.0) pero no va a instalarse
                       Depende: libxcb-glx0:i386 (>= 1.8.1) pero no va a instalarse
                       Depende: libxxf86vm1:i386 (>= 1.1.2) pero no va a instalarse
                       Depende: libdrm2:i386 (>= 2.4.40) pero no va a instalarse
                       Depende: libgfortran3:i386 (>= 4.7.2) pero no va a instalarse
                       Depende: libquadmath0:i386 (>= 4.7.2) pero no va a instalarse
    E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).
    Desde el soporte técnico del software me dijeron que ejecutara #apt-get install -f (que ya se había hecho) luego de la instalación. Es decir, luego de ejecutar # dpkg -i mestrenova_9.0.0-12821_i386.deb

    Código:
    # apt-get install -f
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias       
    Leyendo la información de estado... Hecho
    Corrigiendo dependencias... Listo
    Los siguientes paquetes se ELIMINARÁN:
      mestrenova:i386
    0 actualizados, 0 se instalarán, 1 para eliminar y 0 no actualizados.
    1 no instalados del todo o eliminados.
    Se liberarán 342 MB después de esta operación.
    ¿Desea continuar [S/n]?  
    (Leyendo la base de datos ... 99308 ficheros o directorios instalados actualmente.)
    Desinstalando mestrenova ...
    dpkg: aviso: al desinstalar mestrenova, el directorio «/usr/local/share» no está vacío, por lo que no se borra
    Alguna sugerencia de que puede estar pasando o de como averiguarlo?

    Desde ya muchas gracias
    Última edición por Tini; 21-05-2014 a las 16:49
    Citar  
     

Temas similares

  1. DEBIAN y POSTGRESQL
    Por rower en el foro BASES DE DATOS
    Respuestas: 3
    Último mensaje: 28-08-2008, 15:52
  2. Debian
    Por RaidMan en el foro LINUX - MAC - OTROS
    Respuestas: 12
    Último mensaje: 26-06-2007, 14:25
  3. x en debian
    Por <PICCOLO> en el foro LINUX - MAC - OTROS
    Respuestas: 5
    Último mensaje: 11-03-2003, 00:36
  4. Debian
    Por Xevian en el foro LINUX - MAC - OTROS
    Respuestas: 0
    Último mensaje: 29-04-2002, 18:05
  5. RPC en Debian
    Por dark_eyes en el foro LINUX - MAC - OTROS
    Respuestas: 0
    Último mensaje: 27-12-2001, 03:43

Marcadores

Marcadores

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •