Resultados 1 al 3 de 3

Tema: Problema Metasploits

  1. #1 Problema Metasploits 
    Iniciado
    Fecha de ingreso
    Nov 2010
    Mensajes
    16
    Descargas
    0
    Uploads
    0
    Hola de Nuevo,
    Ya he comentado este problema en otros lugares y no consigo que nadie sepa contestarme a el.
    Recientemente estoy empezando a utilizar Metasploits, la verdad que desde el entorno grafico me va bien, pero claro empece a utilizarlo desde a consola y me surgio la idea de exportar los resultados de Nessus a el MSF.
    Empece a investigar y despues de leer, comprendi que tenia que crear una base de datos con los resultados de Nessus en archivo .nbe, pero a la hora de lanzar el comando db_create me devuelve este mensaje:
    This database command requires the following tools to be installed: dropdb
    Supuse que debia instalar ese archivo o repositorio. el problema surge cuando intento instalarlo, este comando para instalarlo atraves de Ruby: gem install dropdb y nada me devuleve esto: could not find gem dropdb locally or in a repository .
    Por lo cual supongo que no esta en los repositorios el llamado dropdb.
    He leido soble crear la base de datos con pgAdmin III pero al crearla me conecto a ella pero no se seguir a partir de hay, no se crear la base de datos con el archivo .nbe.
    Aparte si quiero importar directamente el archivo .nbe de este modo: db_import_nessus_nbe "ruta archivo" me devuelve esto : Database no connect

    Alguien sabria que pasa como puedo hacelo?
    Trabajo sobre Windows demomento, estoy intentando cambiar a Linux.
    Gracias de Antemano
    Saludos.
    Citar  
     

  2. #2  
    Co-Admin HackHispano.com Avatar de clarinetista
    Fecha de ingreso
    Jan 2004
    Ubicación
    HackHispano/SM
    Mensajes
    7.733
    Descargas
    30
    Uploads
    8
    Citar  
     

  3. #3  
    Iniciado
    Fecha de ingreso
    Nov 2010
    Mensajes
    16
    Descargas
    0
    Uploads
    0
    Muchisimas Gracias por tu respuesta Clarinetista,
    He leido los manuales y los comprendo perfectamente, se el funcionamiento basico del programa y como se deberia poder hacer la base de datos, pero nada......., sigo igual, no se que es lo que pasa, bueno creo que si se lo que pasa, bajo mi punto de vista creo que faltan los archivos: psql, dropdb, createdb.
    Pero no se como instalarlos, he probado desde ruby, con los siguientes comandos: gem install dropdb, gem install drop, gem install psql, gem install createdb y gem install create, con identico resultado: could not find gem "Archivo a instalar" locally or in a repository.
    No se como poder instalarlos, porque si me dice que no estan en los repositorios no se como puedo instalarlos en el programa, porque para cualquier función relacionada con las bases de datos me pide dichos archivos. Con lo cual no puedo trabajar importando los resultados de Nessus.
    He buscado por todos lados que he podido, y nada, a nadie le ha dado ese problema, al menos que yo encuentre, si alguien sabe sobre el programa, por favor que comente.
    Muchisimas gracias de antemano.
    Saludos.
    Citar  
     

Etiquetas para este tema

Marcadores

Marcadores

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •