Página 1 de 3 123 ÚltimoÚltimo
Resultados 1 al 20 de 44

Tema: no hiberna en ubuntu

  1. #1 no hiberna en ubuntu 
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    ah! y tambien me ha dejado de hibernar el ordenador.
    No tengo ni idea porque. Y eso que instale "lphdisk"...

    Es un Vaio con una Phoenix de bios.
    Ubuntu 9.04 32 bits.

    Me podeis dar alguna indicacion?

    saludos!!!

    PD: que alguien conteste el post anterior del pidgin... please!
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  2. #2  
    Moderador HH
    Fecha de ingreso
    Sep 2003
    Mensajes
    1.384
    Descargas
    21
    Uploads
    5
    Te tira algun error?

    Saludos
    - Me desagrada
    - ¿Por qué?
    - No estoy a su altura.
    ¿Ha respondido así alguna vez un hombre?

    Friedrich Nietzsche



     

  3. #3  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    gracias por tu interes.

    Pues no, no tira ningun error. No aparece nada. Simplemente inicia sesion como si seria una sesion nueva.

    saludos
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  4. #4  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Mira, en mi equipo:

    dpkg -l | grep acpi

    Código:
    ii  acpi                                 1.4-2                          displays information on ACPI devices
    ii  acpi-support                         0.123-1                        scripts for handling many ACPI events
    ii  acpi-support-base                    0.123-1                        scripts for handling base ACPI events such as the power
    ii  acpid                                1.0.10-2                       Utilities for using ACPI power management
    ii  libacpi0                             0.2-4                          general purpose library for ACPI
    ii  xbattbar-acpi                        1.1.0-1                        Battery monitoring tool for X11
    Salu2

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

  5. #5  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    gracias pero sigue sin hibernar.

    A ver, que pasos harias vosotros para saber que pasa?

    Gracias y saludos
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  6. #6  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    ¿Qué kernel gastas? (puedes mirarlo con `uname -r`)

    Primero debemos distinguir entre suspender (o suspender a RAM) e hibernar (suspender a disco)

    Quizá no esté soportado, mira si te devuelve 'mem' (para suspender) o 'disk' (para hibernar) al ejecutar:
    Código:
    cat /sys/power/state
    Si las cadenas mem y disk aparecen al ejecutar este comando, el problema está en otro sitio.

    Para ver si está configurado en el kernel prueba a hacer:
    grep ACPI_SLEEP /boot/config-$(uname -r)

    Si todo está bien, prueba a instalar el paquete hibernate:
    Código:
    apt-get install hibernate
    Otra opción es el paquete powersaved:
    Código:
    apt-get install powersaved
    Con él puedes ejecutar
    Código:
    powersave -u
    para suspender, y
    Código:
    powersave -U
    para hibernar.


    Ya nos cuentas.

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

  7. #7  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    Bueno, primeramente, muchas gracias por tu amplia explicacion.
    te comento. Hibernar, antes hibernaba, de repente, dejo de hibernar.
    (si. Diferencio entre suspender e hibernar. Yo quiero hibernar)

    uname -r
    2.6.28-14-generic

    cat /sys/power/state
    mem disk

    Powersaved (no lo tenia instalado)
    ha instalado varias librerias...

    grep ACPI_SLEEP /boot/config-$(uname -r)
    CONFIG_ACPI_SLEEP=y

    y ahora mismo voy a probar...
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  8. #8  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    nothing the nothing

    con powersaved da error:
    powersave daemon is already running. If it is not running, delete pid file: /var/run/powersaved.pid

    y con hibernate (que ya estaba instalado) se cuelga

    ...
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  9. #9  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Creo que has probado

    Código:
    powersaved -U
    Por eso ha tratado de lanzar el demonio de nuevo.

    Prueba (sin la d final)

    Código:
    powersave -U

    Salu2

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

  10. #10  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    nada.

    Cuando vuelvo a encender, hace un inicio de sesion nuevo, no restaura la hibernacion....


    ay...
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  11. #11  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Cita Iniciado por 1fluke2 Ver mensaje
    Cuando vuelvo a encender, hace un inicio de sesion nuevo, no restaura la hibernacion....
    ¿En ambos casos?¿Tanto con S3 como con S4?

    El caso es que los fabricantes suelen implementar acpi de forma distinta. Un recurso que te podría ser interesante, ya que expone casos de instalación de Linux (y otros sistemas operativos), es éste: http://tuxmobil.org/mylaptops.html


    Salu2

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

  12. #12  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    gracias por tu apoyo.

    Pues con "-u" (suspender) vuelve correctamente.
    pero con "-U" (hibernar) inicia nueva sesion.

    ¿puede ser algo del arranque?

    saludotes
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  13. #13  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Cita Iniciado por 1fluke2 Ver mensaje
    gracias por tu apoyo.

    Pues con "-u" (suspender) vuelve correctamente.
    pero con "-U" (hibernar) inicia nueva sesion.

    ¿puede ser algo del arranque?
    Pues la verdad que no lo sé. Sospecho que tenga que ver con la forma en que ubuntu gestiona los discos (by-uuid).

    Yo probaría a sustituir temporalmente el archivo /etc/fstab por uno en el que en vez de especificarse los discos por uuid, se especifiquen por dispositivo (i.e. /dev/sda2).


    Salu2

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

  14. #14  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    vale, voy a probar esto, a ver si no me cargo nada...

    esto tengo
    Código:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sda2 during installation
    UUID=ab9180d6-ad32-416e-9b44-7515c83e815d /               ext4    relatime,errors=remount-ro 0       1
    # swap was on /dev/sda4 during installation
    UUID=6b10cd62-c478-43af-81c9-95203bbf8a16 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0

    confirmamelo, please
    y creo que hay que hacer esto
    Código:
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # / was on /dev/sda2 during installation
    (hay que poner algo delante?)/dev/sda2               ext4    relatime,errors=remount-ro 0       1
    # swap was on /dev/sda4 during installation
    UUID=6b10cd62-c478-43af-81c9-95203bbf8a16 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  15. #15  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    sí, yo lo veo bien así.


    Salu2

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

  16. #16  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    nada.
    Seguimos igual...

    que mas podemos probar?
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  17. #17  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    El problema está en que el hardware no está bien soportado, por culpa sobre todo del ACPI mismo, que cada uno lo implementa como dios le dió a entender. Las BIOS cerradas y propietarias son las culpables últimas de que esto suceda.

    Pero me temo que además hay problemas a nivel de kernel y de controladores, que vienen a empeorar el problema.

    Aquí tienes una charla más en profundidad al respecto.
    http://video.google.com/videoplay?do...09273628599358


    Un intento más:

    Prueba a editar /etc/acpi-support y cambiar el tipo de suspensión predeterminada.

    Es decir, cambia CPI_SLEEP_MODE a suspend

    Salu2

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

  18. #18  
    Moderador HH
    Fecha de ingreso
    Sep 2003
    Mensajes
    1.384
    Descargas
    21
    Uploads
    5
    Acabo de leer de nuevo el primer post y veo que dice:
    no hiberna en ubuntu:
    ah! y tambien me ha dejado de hibernar el ordenador.
    Por lo que puedo suponer que tampoco te hiberna en otros SO. no?

    Si es asi fijate que tengas habilitado S4 en el modo ACPI en la bios.

    Saludos
    - Me desagrada
    - ¿Por qué?
    - No estoy a su altura.
    ¿Ha respondido así alguna vez un hombre?

    Friedrich Nietzsche



     

  19. #19  
    Avanzado
    Fecha de ingreso
    Jul 2007
    Ubicación
    en Linux ;D
    Mensajes
    334
    Descargas
    4
    Uploads
    0
    No, no. A ver.
    En windows si hiberna.
    Y tras instalar ubuntu, ubuntu mismo hibernaba correctamente (con kernel 2.6.28-11)

    Pero fue tras instalar o actualizar algo que no "resume" bien.

    Y no existe el archivo acpi-support en /etc/
    Esta en /etc/default/acpi-support
    ...
    Código:
    #
    # Configuration file for the acpi-support package
    
    SUSPEND_METHODS="dbus-pm dbus-hal pm-utils"
    
    # Comment the next line to disable ACPI suspend to RAM
    ACPI_SLEEP=true
    
    # Comment the next line to disable suspend to disk
    ACPI_HIBERNATE=true
    
    # Change the following to "standby" to use ACPI S1 sleep, rather than S3.
    # This will save less power, but may work on more machines
    ACPI_SLEEP_MODE=mem
    
    # unless they're listed in MODULES_WHITELIST
    MODULES=""
    
    MODULES_WHITELIST=""
    
    # Should we save and restore state using the VESA BIOS Extensions?
    SAVE_VBE_STATE=true
    
    # The file that we use to save the vbestate
    VBESTATE=/var/lib/acpi-support/vbestate
    
    # Should we attempt to warm-boot the video hardware on resume?
    POST_VIDEO=true
    
    # Save and restore video state?
    # SAVE_VIDEO_PCI_STATE=true
    
    USE_DPMS=true
    
    # RADEON_LIGHT=true
    
    # DOUBLE_CONSOLE_SWITCH=true
    
    # Set the following to "platform" if you want to use ACPI to shut down
    # your machine on hibernation
    HIBERNATE_MODE=shutdown
    
    LOCK_SCREEN=true
    # DISABLE_DMA=true
    
    # Uncomment this line to attempt to reset the drive on resume. This seems
    # to be needed for some Sonys
    # RESET_DRIVE=true
    
    STOP_SERVICES=""
    
    RESTART_IRDA=false
    
    ENABLE_LAPTOP_MODE=false
    
    SKIP_INTERFACES="dummy qemu"
    
    # Note: to enable "laptop mode" (to spin down your hard drive for longer
    # periods of time), install the laptop-mode-tools package and configure
    # it in /etc/laptop-mode/laptop-mode.conf.


    Venga, vamos a seguir probando. Imaginad que tenies este ordenador. Lo que haga falta, hare. OK?
    Última edición por 1fluke2; 11-08-2009 a las 10:29
    * * @* * Olvídate de:
    *@ @* * los anti-virus, anti-spyware, anti-nada y anti-todo.
    * * @* * y del software que expira a los 30 días
    * * @* *
    * @@@* linux
     

  20. #20  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Si en una versión anterior te funcionaba, entonces en este caso es claramente cosa de la distro.

    Quizá sea incluso sólo cosa del kernel, Prueba de nuevo co un 2.6.28-11, a ver si así te funciona.

    Si no te funciona, encuentra los cambios que se han producido entre el estado anterior de la distribución y éste.


    Salu2

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
     

Temas similares

  1. Ubuntu 10.04
    Por Yan125 en el foro LINUX - MAC - OTROS
    Respuestas: 12
    Último mensaje: 27-06-2010, 21:42
  2. Sniffear red ubuntu
    Por chusrubi2 en el foro INTRUSION
    Respuestas: 4
    Último mensaje: 21-01-2010, 01:44
  3. No arranca Cd- Ubuntu
    Por molinardo en el foro LINUX - MAC - OTROS
    Respuestas: 18
    Último mensaje: 03-03-2009, 03:14
  4. Ubuntu 7.10
    Por LeRaS en el foro LINUX - MAC - OTROS
    Respuestas: 5
    Último mensaje: 09-11-2007, 18:05
  5. dudas en ubuntu
    Por rower en el foro LINUX - MAC - OTROS
    Respuestas: 11
    Último mensaje: 30-05-2007, 21:26

Marcadores

Marcadores

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •