Resultados 1 al 6 de 6

Tema: Error en la configuración del teclado (Ubuntu)

  1. #1 Error en la configuración del teclado (Ubuntu) 
    Iniciado
    Fecha de ingreso
    Sep 2007
    Mensajes
    3
    Descargas
    0
    Uploads
    0
    Hola, el otro día traté de instalar unos drivers para la tarjeta gráfica (que por cierto, al final no fui capaz) y me empezó a preguntar cosas sobre la tarjeta gráfica y sobre el teclado (¿¿¿???). Era un cuestionario larguísimo y absurdo, yo me dediqué a poner más o menos lo que creo que es la configuración estándar. Sin embargo, metí la gamba, pero pude reconfigurar lo de la tarjeta gráfica con un comando y se quedó como estaba en un principio.

    Pero el problema ahora es para reconfigurar el teclado y dejarlo como estaba, mi problema principal es que no puedo usar la combinación Alt + Número (por ejemplo, la arroba o los corchetes).
    Cuando reinicié el ordenador por primera vez que dijo que era diferente la configuración de teclado de "X" a la de Ubuntu. La diferencia es que para "X" establecí "nondeadkeys". Me daba a elegir cuál quería de las dos y elegí la de "X" (ahora sé que no debería haberlo hecho).

    No sé si existe algún comando como el que utilicé para reconfigurar la tarjeta gráfica (sería lo ideal), porque entrando en los ajustes de teclado de Ubuntu, me da este mensaje al pulsar "Restablecer valores predeterminados" me sale este mensaje:

    Error al activar la configuración XKB.
    Podría deberse a varias circunstancias:
    - un fallo en la biblioteca libxklavier.
    - un fallo en el servidor X (utilidades xkbcomp, xmodmap)
    - Un servidor X con una implementación incompatible con libxkbfile

    Datos de la versión del servidor X:
    The X.Org Foundation
    70200000

    Si informa de esta situación como un fallo, por favor incluya:
    - El resultado de xprop -root | grep XKB
    - El resultado de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
    Éste es el resultado de xprop -root | grep XKB

    _XKB_RULES_NAMES_BACKUP(STRING) = "xorg", "pc105", "es", "nondeadkeys", ""
    _XKB_RULES_NAMES(STRING) = "xorg", "pc105", "es", "nondeadkeys", ""
    Y éste el de gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
    layouts = []
    model =
    overrideSettings = true
    options = []


    Espero haber expresado bien mi problema y confío en que podáis ayudarme.


    Un saludo.
    Citar  
     

  2. #2  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Prueba a quitar 'nondeadkeys'

    _XKB_RULES_NAMES(STRING) = "xorg", "pc105", "es", "", ""
    Puedes editar el ficher /etc/X11/xorg.conf a mano y reiniciar las X para ver los cambios y la nueva salida de xprop

    Salu2
    Última edición por j8k6f4v9j; 02-09-2007 a las 02:11

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

  3. #3  
    Iniciado
    Fecha de ingreso
    Sep 2007
    Mensajes
    3
    Descargas
    0
    Uploads
    0
    Es una buena idea, sí señor.

    Tengo entendido que sólo puedo editar xorg.conf con tty, sin entorno gráfico. El problema es que para entrar hay que pulsar Ctrl+Alt+F1, y como tengo el teclado desconfigurado no me funciona (¡ja, vaya mala pata!)

    ¿Hay alguna forma alternativa para acceder a tty?
    Citar  
     

  4. #4  
    Avanzado
    Fecha de ingreso
    Jan 2004
    Ubicación
    Donde me dejan
    Mensajes
    433
    Descargas
    7
    Uploads
    0
    No hace falta que lo hagas desde la consola sin las X puedes abrir una consola en ubuntu y realizarlo desde alli y ademas si lo prefieres en modo grafico al abrir el arxivo xorg.conf hazlo desde la consola, y ademas recuerda pedir derechos de root, es decir:

    sudo kate xorg.conf

    este seria mi caso en Kde (Kubuntu) en Gnome no se que programa utilizais.

    Saludos
    El mejor maestro es uno mismo, aun que siempre va bien una ayudita
    Citar  
     

  5. #5  
    Iniciado
    Fecha de ingreso
    Sep 2007
    Mensajes
    3
    Descargas
    0
    Uploads
    0
    Muchas gracias, ya he conseguido solucionar el problema, sólo he tenido que poner como root "nano /etc/X11/xorg.conf" y borrar esa línea.


    @@@@@@@@@@@@@@!!!!!!!!
    Citar  
     

  6. #6  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    De nada Para eso estamos

    Salu2


    Keep on Rollin'

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

Temas similares

  1. Respuestas: 1
    Último mensaje: 29-11-2013, 23:58
  2. problemas en configuracion en ubuntu
    Por kashanty en el foro REDES Y TECNOLOGIAS WIRELESS
    Respuestas: 0
    Último mensaje: 17-05-2009, 22:53
  3. Error en ubuntu
    Por rat en el foro LINUX - MAC - OTROS
    Respuestas: 6
    Último mensaje: 19-01-2009, 18:37
  4. Error al instalar ubuntu
    Por Daniel666999 en el foro LINUX - MAC - OTROS
    Respuestas: 9
    Último mensaje: 02-08-2008, 11:41
  5. Problemas con teclado
    Por nakoplass en el foro HARDWARE
    Respuestas: 1
    Último mensaje: 16-10-2006, 04:24

Marcadores

Marcadores

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •