Resultados 1 al 12 de 12

Tema: Driver de rtl8180L en Kernel 2.6.17

  1. #1 Driver de rtl8180L en Kernel 2.6.17 
    Iniciado
    Fecha de ingreso
    Jul 2006
    Mensajes
    18
    Descargas
    5
    Uploads
    0
    Estoy con problemas para instalar el driver de una tarjeta de red wireless (creo que se dice asi)

    Tarjeta: Realtek, chipset: rtl8180L

    Consegui unos driver para instalar. El problema que tengo es que al ejecutar 'make' da algunos errores.

    Código:
    root@Apollo:DrvRealtek/rtl8180-0.21# make
    make -C /lib/modules/2.6.17/build SUBDIRS=/DrvRealtek/rtl8180-0.21 MODVERDIR=/DrvRealtek/rtl8180-0.21 modules
    make[1]: se ingresa al directorio `/usr/src/linux-2.6.17'
    Makefile:266: /usr/src/linux-2.6.17/scripts/Kbuild.include: No existe el fichero o el directorio
    Makefile:486: /usr/src/linux-2.6.17/arch/i386/Makefile: No existe el fichero o el directorio
    make[1]: *** No hay ninguna regla para construir el objetivo `/usr/src/linux-2.6.17/arch/i386/Makefile'.  Alto.
    make[1]: se sale del directorio `/usr/src/linux-2.6.17'
    make: *** [2.6] Error 2
    He seguido varios tutoriales que he encontrado por ahi y no he conseguido que no salga este error. Tambien he seguido un tutorial que encontre aqui mismo en HakHispano, pero nada.

    Preguntas:
    1) ¿Que significa este error? (no he podido averiguarlo )
    2) ¿Como puedo solucionarlo?

    Desde ya muchas
    Citar  
     

  2. #2  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Has instalado los headers de tu kernel? Leíste la documentación (README) del driver? Tienes todas las herramientas necesarias?

    Salu2


    Keep on Rollin'

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

  3. #3  
    Iniciado
    Fecha de ingreso
    Jul 2006
    Mensajes
    18
    Descargas
    5
    Uploads
    0
    Guenas, desde ya muchas gracias por contestar.

    Headers: Trate de instalarlos usando apt-get y me dio problemas, por lo que supuse que ya estaban. Pero no se como hacer para saber si estan instalados y si no es asi cuales preciso.

    README: Siguiendo los pasos de este y los de INSTALL es que llegue a este error. Los lei completamente y luego trate de hacer la instalacion.

    Con respecto a las herramientas necesarias, no se que mas puedo estar necesitando.
    Citar  
     

  4. #4  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Es comprensible que estés algo liado si no estás muy acostumbrado. Has de entender que el README y el INSTALL son una secuencia estricta. Es decir, debes seguirlos pasoa a paso y ver dónde se produce el fallo. Sin un error exacto son imposibles un análisis y diagnóstico exactos.

    Para los headers puedes hacer:
    Código:
    apt-cache search kernel-headers-$(uname -r) && apt-cache search linux-headers-$(uname -r)
    E instalar el paquete que te devuelva la búsqueda. Si recibes un error pégalo aquí o léelo para determinar de qué se trata.

    Salu2


    Keep on Rollin'

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

  5. #5  
    Iniciado
    Fecha de ingreso
    Jul 2006
    Mensajes
    18
    Descargas
    5
    Uploads
    0
    Bueno...
    Al parecer y gracias a la sugerencia, aparecio el problema. NO ESTAN LOS HEADERS.

    El comando utilizando 'serch' no sirvio, por lo que buscando en la ayuda encontre que debia utilizar 'policy'
    Lo que aparecio es lo siguiente:
    Código:
    :/# apt-cache policy kernel-headers-$(uname -r) linux-headers-$(uname -r)
    W: No se ha podido localizar el paquete kernel-headers-2.6.17
    W: No se ha podido localizar el paquete linux-headers-2.6.17
    Ya me pongo a buscar estos paquetes.
    Supongo que los puedo localizar e instalar sin usar el comando 'apt-get install'? Si no se puede ¿como lo debo hacerlo?
    Última edición por Tini; 05-06-2007 a las 00:37 Razón: Error en lo escrito
    Citar  
     

  6. #6  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    apt es la opción más sencilla para instalar esos paquetes. Es extraño que no los localice, es posible que no los tengas en los repositorios. Puedes ver cómo funciona el manejador de paquetes con el comando
    Código:
    man apt
    Las cabeceras del kernel te sirven para no tener que instalar las fuentes completas del kernel. Sí que es posible instalar todo sin apt, tendrías que localizar el código fuente, descomprimirlo en algún lugar de tu sistema de ficheros y compilarlo. Es mucho más sencillo añadir las direcciones correctas a tu fichero /etc/apt/sources.list e instalar esos headers que te faltan tras actualizar tus repositorios con
    Código:
    apt-get update
    Es conveniente siempre saber de qué sistema se está hablando. Para que lo sepamos pega aquí la salida que obtienes con el comando
    Código:
    uname -a
    Salu2


    Keep on Rollin'

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

  7. #7  
    Iniciado
    Fecha de ingreso
    Jul 2006
    Mensajes
    18
    Descargas
    5
    Uploads
    0
    Con el comando 'uname -a' sale esto:
    Código:
    /# uname -a
    Linux Apollo 2.6.17 #4 SMP PREEMPT Wed May 10 13:53:45 CEST 2006 i686 GNU/Linux
    Con respecto a lo que mencionabas del comando 'apt-get update', se que esa es la forma mas comoda de hacerlo. Pero se me complica un poco acercar el router hasta la computadora y poder conectarme por la eth0. Ya vere como le hago para traerme el router por un rato.

    A estas alturas ya me deberia haber dado cuenta, pero... Que cabeceras son las que tengo que instalar. Porque he encontrado de todo un poco, pero todo lo que he encontrado siempre tiene mas numeros que los de la version del kernel (2.6.17).

    Gracias por la paciencia
    Citar  
     

  8. #8  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Ése es justo el problema.

    Te explico, cuando tú haces `uname -r` lo que le estás diciendo a uname es que te devuelva sólo la parte de `uname -a` correspondiente a la versión de tu kernel. Ésta es 2.6.17, por eso los comandos apt-cache search no te devuelven la versión correcta de headers para tu kernel.

    Lo que puedes hacer es buscar nuevas imágenes de kernels para usar, en lugar de la versión 2.6.17. Por ejemplo, puedes usar la linux-image-2.6.18-4-486 con sus headers. Sería algo como
    Código:
    apt-get install linux-headers-2.6.18-4-486 linux-image-2.6.18-4-486
    Para saber cuáles tienes disponibles:
    Código:
    apt-cache search linux-image && apt-cache search linux-headers
    Elige una imagen de la cuál tengas los headers de exactamente la misma versión.
    Ten en cuenta que al instalar una nueva imagen te sobreescribirá el archivo de configuración del grub en /boot/grub/menu.lst. Por lo que si tienes alguna entrada especial de arranque (un *BSD, otros GNU/linux, etc) será borrada. Es conveniente entonces que hagas copia de respalde de es te archivo antes de instalar.

    Salu2


    Keep on Rollin'

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

  9. #9  
    Iniciado
    Fecha de ingreso
    Jul 2006
    Mensajes
    18
    Descargas
    5
    Uploads
    0
    Guenas
    Linda y complicada noche que tuve....

    Primero: j8.. gracias por la mano que me has estado dando, y a todo el que aporte tambien

    Ahora vamos al grano
    Actualice tanto el kernel como las cabeceras a la version '2.6.21-1-486', previo a esto actualice los repositorios ('apt-get update'). Me parece que debo aclarar que como no tengo algunas cosas claras (por ejemlo las dependencias) utilice el manejador de paquetes 'Synaptic' (tambien actualice los repositorios del programa)

    El comando 'make' me sigue dando problemas. Ahora si estoy seguro de que las cabeceras estan.
    Les dejo lo que me aparece en la consola, a ver si a alguien se le ocurre algo...
    Código:
    root@Apollo:/home/Tini/rtl818x-1.0.1-b# make
    make -C /lib/modules/`uname -r`/build SUBDIRS=`pwd`/net/ieee80211 CONFIG_IEEE80211=m CONFIG_IEEE80211_CRYPT=m CONFIG_IEEE80211_CRYPT_WEP=m CONFIG_IEEE80211_CRYPT_CCMP=m CONFIG_IEEE80211_CRYPT_TKIP=m CC="gcc -I`pwd`/include" modules
    make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.21-1-486'
      CC [M]  /home/Tini/rtl818x-1.0.1-b/net/ieee80211/ieee80211_module.o
    /home/Tini/rtl818x-1.0.1-b/net/ieee80211/ieee80211_module.c:36:26: error: linux/config.h: No existe el fichero o el directorio
    make[2]: *** [/home/Tini/rtl818x-1.0.1-b/net/ieee80211/ieee80211_module.o] Error 1
    make[1]: *** [_module_/home/Tini/rtl818x-1.0.1-b/net/ieee80211] Error 2
    make[1]: se sale del directorio `/usr/src/linux-headers-2.6.21-1-486'
    make: *** [modules] Error 2
    
    root@Apollo:/# uname -a
    Linux Apollo 2.6.21-1-486 #1 Sat May 26 15:35:16 UTC 2007 i686 GNU/Linux
    Como ven tambien dejo lo que aparece con 'uname -a'

    Escucho sugerencias...
    Citar  
     

  10. #10  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    He estado investigando un poco sobre el tema.

    Es posible que se trate de alguna incompatibilidad relacionada con los includes del kernel.

    ¿Son las fuentes del driver actuales?

    Lo mejor sería advertir al encargado de mantener el driver acerca del cambio en el fichero config.h. Si no quieres/puedes hacerlo puedes pegar aquí la fuente de la que obtuviste el driver para que nosotros hagamos dicho reporte.

    Prueba a descargarte el archivo de http://picksource.com/config.h y a situarlo en el directorio que contiene los includes para el kernel y a recompilar de neuvo el driver. Si vuelves a obtener errores vuelve a publicarlos y vemos fqué se puede hacer al respecto.

    Gracias a pickcoder de #debian en irc.freenode.net

    Salu2


    Keep on Rollin'

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

  11. #11  
    Iniciado
    Fecha de ingreso
    Jul 2006
    Mensajes
    18
    Descargas
    5
    Uploads
    0
    No tengo idea si las fuentes del driver son actuales, lo que si se es que dice que son compatibles con 'Kernel 2.6.x'
    Tampoco recuerdo de donde fue que las baje.

    Probe de bajar el archivo 'config.h', pero la verdad es que como no sabia donde tenia que ubicarlo probe en varios lugares y no consegui nada. No estoy muy seguro de que son los 'includes', estuve buscando informacion pero no me quedo del todo claro. De todas formas el mensaje de error sigue siendo el mismo.

    Te agradesco por toda la ayuda, pero todo esto logro sacarme de quisio... Por lo que termine probando una distro distinta. Al final instale Kubuntu 7.04. En esta no tuve que hacer nada para que reconociera la dichosa tarjeta de red. De todas formas intentare satisfacer mi curiosidad personal y voy a seguir investigando que fue lo que paso...

    Otra pregunta:
    ¿Como puedo saber que driver y/o herramientas esta usando Kubuntu para la tarjeta?
    No se si fui claro. Quiero saber que paquetes hacen que este sistema si pueda reconocer y usar la tarjeta.
    Última edición por Tini; 22-06-2007 a las 00:36
    Citar  
     

  12. #12  
    Moderador Global
    Fecha de ingreso
    Aug 2005
    Mensajes
    6.279
    Descargas
    7
    Uploads
    0
    Cita Iniciado por Tini Ver mensaje
    No tengo idea si las fuentes del driver son actuales, lo que si se es que dice que son compatibles con 'Kernel 2.6.x'
    Tampoco recuerdo de donde fue que las baje.
    Imagina que eso se escribió cuando la última versión de kernel 2.6.x era la 2.6.4, y que ahora va por la 2.6.18-4.

    Si ha habido cambios en la localización de los archivos por ejemplo (parece ser el caso), el módulo ya no será estrictamente compatible hasta que no se le hagan unas pequeñas modificaciones a las configuraciones.

    Otra pregunta:
    ¿Como puedo saber que driver y/o herramientas esta usando Kubuntu para la tarjeta?
    No se si fui claro. Quiero saber que paquetes hacen que este sistema si pueda reconocer y usar la tarjeta.
    Puedes ver un listado completo de los módulos que está usando el sistema mediante el comando:
    Código:
    lsmod
    lo que pasa es que ubuntu y kubuntu usan una cantidad ingente de éstos, ya se ha hablado aquí sobre las similitudes entre ubuntu y güindous.
    Una forma un tanto primitiva de hacerlo es investigar esos módulos que hay cargados para ver cuál puede ser y, si crees que puede ser uno en concreto, tirarlo para luego comprobar que la tarjeta ha dejado de funcionar
    Código:
    modprobe -r nombre_del_modulo
    Salu2


    Keep on Rollin'

    . . . . . . . . . . . . . . . . . . . .
    [[ NORMAS DEL FORO ]]
    . . . . . . . . . . . . . . . . . . . .
    __________
    Citar  
     

Temas similares

  1. kernel
    Por ROMAN LOPEZ en el foro WINDOWS
    Respuestas: 4
    Último mensaje: 17-12-2006, 14:28
  2. Kernel 2.4.20
    Por rPcW0rM en el foro LINUX - MAC - OTROS
    Respuestas: 1
    Último mensaje: 17-01-2003, 00:38
  3. Actualisacion del kernel
    Por Tripa en el foro LINUX - MAC - OTROS
    Respuestas: 7
    Último mensaje: 14-08-2002, 14:41
  4. kernel
    Por E__I en el foro LINUX - MAC - OTROS
    Respuestas: 1
    Último mensaje: 06-06-2002, 01:36
  5. Kernel
    Por Giskard en el foro LINUX - MAC - OTROS
    Respuestas: 4
    Último mensaje: 26-03-2002, 23:22

Marcadores

Marcadores

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •