Resultados 1 al 9 de 9

Tema: Lecturas del 12C509

  1. #1 Lecturas del 12C509 
    Iniciado
    Fecha de ingreso
    Nov 2006
    Mensajes
    8
    Descargas
    0
    Uploads
    0
    Tengo un problema muy extraño con el pic (llevo ya 5). Resulta que siguiendo las instrucciones de configuración del ICProg, grabo el PIC, y me da verificación correcta. El problema que tengo es que si después lo leo para ver los resultados, me aparece algo totalmente distinto, que varía entre 3 ó 4 checksums distintos.

    En una de las ocasiones probé en otro portátil y tardó bastante más en grabarlo. Pero igual que el resto, al leer daba checksums distintos al original. La diferencia es que en este último PIC si he llegado a ver el hex tal cual lo grabé, pero vuelvo a leerlo y ya da otro checksum.

    Mi pregunta es si a alguien le ha ocurrido esto. Uso un programador T20 con 3 zócalos y smartcard. He probado en 2 portátiles distintos, y el próximo día tengo pensado probarlo en un sobremesa. ¿Es por grabarlo con un portátil? ¿Es el programador?

    Por cierto, no estoy haciendo lo de copiar el último dato del búfer leido, parece que no es necesario.

    ¡Gracias!
    Citar  
     

  2. #2  
    Avanzado
    Fecha de ingreso
    Dec 2005
    Ubicación
    en el mundo mundial
    Mensajes
    311
    Descargas
    0
    Uploads
    0
    Buenas, tiene el portatilpuerto serie? o lo grabas por usb? si es por usb, no esmuy fiable, ya que le falta alimentación para grabar deforma correcta, prueba en el de sobremesa y se quitaran gran parte de tus problemas.
    Salu2
    Creo que el sexo es una de las cosas más bonitas, naturales y gratificantes que se pueden comprar.
    Citar  
     

  3. #3  
    Iniciado
    Fecha de ingreso
    Nov 2006
    Mensajes
    8
    Descargas
    0
    Uploads
    0
    Cita Iniciado por patatapool
    Buenas, tiene el portatilpuerto serie? o lo grabas por usb? si es por usb, no esmuy fiable, ya que le falta alimentación para grabar deforma correcta, prueba en el de sobremesa y se quitaran gran parte de tus problemas.
    Salu2
    Ambos portátiles tienen puerto serie, pero empiezo a sospechar que quizá, por necesidades específicas del 12c509, necesite más intensidad de corriente para grabarse bien. No se en qué post leí que si no recibía suficiente corriente se estropeaba...

    Aunque tampoco tengo claro que ese programador funcione bien para estos, no tengo conmigo un T20 minimalista (18pines + 4 pines) que quizá haga mejor el trabajo al necesitar menos componentes. Mañana pruebo en el sobremesa para ver si van por ahí los tiros...

    Una pregunta aunque parezca obvia: ¿las lecturas de un 12c509 grabado deben ser siempre iguales?

    Gracias por la sugerencia.
    Citar  
     

  4. #4  
    Medio
    Fecha de ingreso
    May 2006
    Mensajes
    52
    Descargas
    0
    Uploads
    0
    Eso mismo me sucede a mi, la razon no la se, lo que se es que funciona igual aunque te de cosas distintas al leerlo, sin embargo los que hacia con el hexgen, no tenian ese problema y lo que escribias luego te lo leia igual.
    Tambien utilizo te20 casero y lo conecto a puerto serie de un PC de sobremesa.

    SALUDOS
    Antes conocido como manolillogrillo.
    Citar  
     

  5. #5  
    Iniciado
    Fecha de ingreso
    Nov 2006
    Mensajes
    8
    Descargas
    0
    Uploads
    0
    Cita Iniciado por parsytectbc
    Eso mismo me sucede a mi, la razon no la se, lo que se es que funciona igual aunque te de cosas distintas al leerlo, sin embargo los que hacia con el hexgen, no tenian ese problema y lo que escribias luego te lo leia igual.
    Tambien utilizo te20 casero y lo conecto a puerto serie de un PC de sobremesa.

    SALUDOS
    Vaya cosa rara. Entonces me dices que los Ali que has grabado, a pesar de dar lecturas distintas, funcionan OK. El problema es que a mí no me lo resetea, el F0 se queda en E8 y no arranca automáticamente. Estoy por probar suerte con el hexgen...
    Citar  
     

  6. #6  
    Iniciado
    Fecha de ingreso
    Nov 2006
    Mensajes
    8
    Descargas
    0
    Uploads
    0
    Acabo de tirar el último de los pic que había comprado para el tema. Este último con Hexgen3, y lo mismo.

    Ya sólo creo que haya 2 puntos de fallo: programador defectuoso, y portátiles que no entregan suficiente corriente al puerto serie.

    Ya doy por hecho que un 12C509A bien grabado y en buen estado siempre debe producir la misma lectura.
    Citar  
     

  7. #7  
    Iniciado
    Fecha de ingreso
    Nov 2006
    Mensajes
    8
    Descargas
    0
    Uploads
    0
    Vale, soy imbécil total sin remedio.

    Tras 9 pics destruidos, he encontrado la razón de que no funcionen los chips: tras la grabación los leía con el ICprog. Por lo visto, si los lees tras grabarlos (no digo la verificación), se joden.

    A los manuales yo le añadiría la advertencia de que si ha dado verificación durante grabación correcta, NO VOLVERLOS A LEER NUNCA.

    Desde luego...

    Gracias a todos por aportar ideas.
    Citar  
     

  8. #8  
    Medio
    Fecha de ingreso
    May 2006
    Mensajes
    52
    Descargas
    0
    Uploads
    0
    Cita Iniciado por syrou
    Vale, soy imbécil total sin remedio.

    Tras 9 pics destruidos, he encontrado la razón de que no funcionen los chips: tras la grabación los leía con el ICprog. Por lo visto, si los lees tras grabarlos (no digo la verificación), se joden.
    A los manuales yo le añadiría la advertencia de que si ha dado verificación durante grabación correcta, NO VOLVERLOS A LEER NUNCA.

    Desde luego...

    Gracias a todos por aportar ideas.
    ¿¿¿¿¿¿¿¿¿¿¿¿¿¿¿¿?????????????????????

    SALUDOS
    Antes conocido como manolillogrillo.
    Citar  
     

  9. #9  
    Iniciado
    Fecha de ingreso
    Nov 2006
    Mensajes
    8
    Descargas
    0
    Uploads
    0
    Cita Iniciado por parsytectbc
    ¿¿¿¿¿¿¿¿¿¿¿¿¿¿¿¿?????????????????????

    SALUDOS
    Pues eso, que en el momento de grabar uno, según me da verificación correcta lo meto en el CFT, funciona bien. Eran las lecturas que intentaba hacer con el ICProg después lo que se lo cargaban...
    Citar  
     

Temas similares

  1. Disco Duro al 100% de lecturas en Windows 10
    Por eloops en el foro WINDOWS
    Respuestas: 1
    Último mensaje: 17-09-2016, 20:28
  2. Codigo 12c509.hex??
    Por Pana69 en el foro TV CABLE
    Respuestas: 102
    Último mensaje: 23-03-2011, 16:16
  3. Mas lecturas sobre Unix
    Por clarinetista en el foro LINUX - MAC - OTROS
    Respuestas: 1
    Último mensaje: 31-03-2004, 21:24
  4. Lecturas recomendadas sobre Linux
    Por clarinetista en el foro LINUX - MAC - OTROS
    Respuestas: 6
    Último mensaje: 29-03-2004, 20:30
  5. pic 12c509
    Por Canut en el foro GENERAL
    Respuestas: 1
    Último mensaje: 17-03-2002, 13:07

Marcadores

Marcadores

Permisos de publicación

  • No puedes crear nuevos temas
  • No puedes responder temas
  • No puedes subir archivos adjuntos
  • No puedes editar tus mensajes
  •