PDA

Ver la versión completa : Linux, paquetes y dependencias.... ????



Orestes
06-02-2004, 18:10
Quiero instalar apt-get para facilitar el trabajo a la hora de instalar, i bien me pide unas cuantas dependencias
compat-gcc-c++-7.3-2.96.122.i386.rpm
-compat-gcc-7.3-2.96.122.i386.rpm
glibc-devel-2.3.2-95.3.i386.rpm
glibc-headers-2.3.2-95.3.i386.rpm
glibc-kernheaders-2.4-8.34.i386.rpm
-compat-libstdc++-7.3-2.96.122.i386.rpm
-compat-libstdc++-devel-7.3-2.96.122.i386.rpm

ya esas la puse pero ahora me dice que necesito
librpm-4.0.4.so is needed by apt-0.3.19cnc55-4sp_rh7x
librpmdb-4.0.4.so is needed by apt-0.3.19cnc55-4sp_rh7x
librpmio-4.0.4.so is needed by apt-0.3.19cnc55-4sp_rh7x
entonces busque...

rpm-4.0.4-7x.i386.rpm


rpm -i rpm-1.6.4-7x.i386.rpm
error: failed dependecies
popt = 1.6.4 is needed by rpm-4.0.4-7x

dije para mi "ok" y luego realize esto:

rpm -Fvh popt-1.6.4-7x.i386.rpm
error: failed dependecies
popt =3D 1.6.3 is needed by rpm-4.0.3-1.03

esto me dejo algo loco, entonces probe lo siguiente

rpm -ivh popt-1.6.4-7x.i386.rpm
Preparing... ######################## [100%]
file /usr/include/popt.h from install of popt-1.6.4-7x conflicts with =
the file from package popt-1.6.3-1.03
file /usr/lib/libpopt.a from install of popt-1.6.4-7x conflicts with the =
file from package popt-1.6.3-1.03
file /usr/lib/libpopt.so.0.0.0 from install of popt-1.6.4-7x conflicts =
with the file from package popt-1.6.3-1.03
file /usr/share/man/man3/popt.3.gz from install of popt-1.6.4-7x =
conflicts with the file from package popt-1.6.3-1.03

entonces no entiendo que puede estar mal.

otra cosa cuando instalo me sale:
warning: popt-1.8.1-4.2.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e

Quien puede ayudarme.... gracias.