PDA

Ver la versión completa : Problema con acentos web Zencart



Lagarto
22-02-2014, 03:59
Saludos comunidad:

Primero que nada felicitar a LUK por el foro, hacía mucho que no ingresaba y ahora que lo veo me doy cuenta de que sigue siendo una excelente herramienta para mucha gente.

La pregunta va encaminada a lo siguiente:

Estoy haciendo una web con Zencart (es enfocada a comercio electrónico), pero tengo un problema que me está dando muchos dolores de cabeza. Resulta que primero tenía el idioma de la web en inglés, posteriormente me descargué el paquete en español y lo instalé sin ningún inconveniente (verifiqué bien la versión del paquete para que fuera compatible con la versión Zencart que estoy utilizando).

Sin embargo, el problema surgió después, cuando me percaté de que todas las palabras a las cuales les había puesto acento, me enviaban un error, por ejemplo, en la sección de las "categorías" de la web:

Con el paquete en inglés aparecía: Computación

Ahora con el paquete en español dice: Computación

Investigando encontré que lo que debo hacer es volver a escribir las palabras en español, pero haciendo uso del código ANSI correspondiente al momento de ingresar la palabra en el Zencart, es decir, que debo escribir: Computaci&oacuten

El problema es que ya prácticamente estaba por concluir la página y ahora que me dicen eso, es casi como iniciar de nuevo. :(

¿Alguien sabe si existe alguna manera de que los acentos puedan aparecer bien, sin necesidad de hacerlo palabra por palabra de nuevo?

¡Mil gracias de antemano y muchos saludos a todos!

Wann
22-02-2014, 04:27
Ese tipo de errores se dan porque ha habido un cambio en la codificación de los caracteres. Comprueba que en la cabecera de tu página la codificación se encuentra en UTF-8 que acepta acentos y ñ.
Espero haber solucionado tu problema, un saludo.

Lagarto
23-02-2014, 06:37
Gracias por tu respuesta Wann.

La página en efecto se encontraba con codificación UTF-8, el problema era que mi navegador no jeje :P

Pero ya quedó solucionado. Por cualquier cosa, les pongo el link de un totarial de codificación UTF-8 en Zencart.

Manual Zencart para codificación UTF-8 (http://srw2d.com/sites/default/files/utf-8-zen-cartV1.3.8.pdf)

Muchos saludos!

ma0941987
23-02-2014, 21:13
Gracias por tu respuesta Wann. La página en efecto se encontraba con codificación UTF-8, el problema era que mi navegador no jeje :P Pero ya quedó solucionado. Por cualquier cosa, les pongo el link de un totarial de codificación UTF-8 en Zencart. http://srw2d.com/sites/default/files/utf-8-zen-cartV1.3.8.pdf"]Manual ("[url) Zencart para codificación UTF-8[/URL] Muchos saludos! lol................................. :)

nohesidoyo
14-08-2014, 14:04
Hola,
Particularmente no tengo mucha experiencia en zen cart, pero te puedo decir que me he visto ese mismo problema en plantillas wordpress. La solución suele ser bastante sencilla si trabajamos con programas de edición php como por ejemplo el phpDesigner.
Cuando me encuentro con un archivo codificado en ANSI, lo único que hago es abrirlo con phpDesigner, darle a Archivo-->Codificación-->Selecciono UTF-8 y guardar. Lo vuelvo a subir al servidor y listo. El proceso no dura ni 1 minuto ;D

gondar_f
15-08-2014, 10:52
Hola,
Particularmente no tengo mucha experiencia en zen cart, pero te puedo decir que me he visto ese mismo problema en plantillas wordpress. La solución suele ser bastante sencilla si trabajamos con programas de edición php como por ejemplo el phpDesigner.
Cuando me encuentro con un archivo codificado en ANSI, lo único que hago es abrirlo con phpDesigner, darle a Archivo-->Codificación-->Selecciono UTF-8 y guardar. Lo vuelvo a subir al servidor y listo. El proceso no dura ni 1 minuto ;D

Una buena solución