PDA

Ver la versión completa : Vulnerabilidad en Winamp



calymax
30-08-2004, 03:27
K-otik dio aviso de la publicación de un exploit que, aprovechando una vulnerabilidad crítica en las versiones 5.04 y anteriores del conocido reproductor multimedia Winamp, permite ejecutar código arbitrario. Exploit es una técnica o programa que aprovecha un fallo o hueco de seguridad -una vunerabilidad- existente en un determinado protocolo de comunicaciones, sistema operativo, o herramienta informática.

Entre otras características, Winamp soporta el uso de archivos "skins", que permiten cambiar el aspecto del interfaz gráfico del reproductor. En la práctica, el mencionado exploit utiliza un archivo con extensión ".wsz", formato que corresponde a un skin comprimido con ZIP, para provocar la ejecución de código arbitrario cuando el archivo es cargado por Winamp. El problema se agrava ya que es posible que la descarga y ejecución del archivo malicioso se realice a través de Internet Explorer con tan sólo visitar un sitio, sin que sea necesario que la víctima realice ningún tipo de acción.

Por el momento no hay una actualización que corrija la mencionada vulnerabilidad en Winamp.

http://www.k-otik.net/bugtraq/08262004.Winamp.php-como

diarrea
30-08-2004, 11:35
En primer lugar aquí teneis el exploit: http://www.blackhat.tv/skinhead/skinhead.tgz (no vayáis a abrir el exploit desde el navegador que la cagais jeje.

Y SI se ha publicado una versión que corrige el fallo, concretamente el día 28-08-2004.
La nueva versión del Winamp 5.05 corrige el problema y la podeis encontrar en
http://www.winamp.com/player/free.php

No es la primera vez que pasa algo parecido con los skins del winamp, hace dos años nos encontrábamos con esto: http://www.securiteam.com/windowsntfocus/5KP0D2K80O.html

diarrea
30-08-2004, 11:36
Por cierto, algunos antivirus lo detectan. El panda lo muestra como Exploit/Codebase.g